Краткое описание: инструкция по подключению usb HDD\SSD\flash к роутеру MikroTik. Также будет рассмотрен процесс создания сетевой папки SAMBA, создания пользователей и прав доступа. И в завершении сетевая папка будет подключена на Windows ПК и будет сделан замер скорости чтения\записи:

  1. Подключение usb HDD\SSD\flash к роутеру;
  2. Настройка MikroTik SMB;
  3. Подключение сетевой папки Windows;
  4. Тест скорости SAMBA.

Нужно настроить MikroTik SAMBA?

Подключение usbHDD\SSD\flash к роутеру MikroTik, создание сетевой папки, ограничение доступа с парольной авторизацией.


    Подключение usb HDD\SSD\flash диска к роутеру MikroTik

    В состав тестового стенда будут входить элементы:

    Подключение usb SSD роутеру MikroTik

    Проверка подключения HDD\SSD\flash

    Настройка находится System→Resources→Usb

    Подключение HDD, SSD, flash к MikroTik, проверка

    Если в списке Usb устройств не отображается HDD\SSD\flash, можно попытаться перезагрузить Usb порт.

    Настройка находится System→Routerboard→Usb Power Reset

    Подключение HDD, SSD, flash к MikroTik, перезагрузить Usb порт

    /system routerboard usb power-reset duration=5s

    Форматирование и инициализация HDD\SSD\flash

    Настройка находится System→Disks

    Подключение HDD, SSD, flash к MikroTik, форматирование диска

    Файловая система FAT32 будет иметь ограничение на размер файла равный 4Гб. Чтобы не упираться в это ограничение будет использоваться файловая система EXT3.

    После успешного форматирования, список Disk list будет иметь вид:

    Подключение HDD, SSD, flash к MikroTik, список дисков

    Настройка MikroTik SAMBA(SMB сервер)

    Samba — пакет программ, которые позволяют обращаться к сетевым дискам и принтерам на различных операционных системах по протоколу SMB/CIFS.

    Настройка MikroTik SAMBA(SMB сервер)

    Настройка SMB

    Настройка находится IP→SMB

    Подключение HDD, SSD, flash к MikroTik, настройка SMB

    /ip smb
    set allow-guests=no domain=MikroTik-Config.ukr enabled=yes interfaces=Bridge-LAN

    allow-guests=no отключить гостевой доступ;

    interfaces=Bridge-LAN сетевые ресурсы будут доступны только в локальном размещении(интерфейс Bridge-LAN)

    Добавление пользователя для доступа к сетевой папке

    Настройка находится IP→SMB→Users

    Подключение HDD, SSD, flash к MikroTik, добавление пользователя

    /ip smb users
    add name=mt-user-1 [email protected] read-only=no

    Создание сетевой папки SAMBA

    Настройка находится IP→SMB→Shares

    Подключение HDD, SSD, flash к MikroTik, добавление сетевой папки

    /ip smb shares
    set [ find default=yes ] disabled=yes
    add directory=disk1/Share max-sessions=100 name=Share

    Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

    И вновь созданная папка будет доступна в общем списке(Files):

    Подключение HDD, SSD, flash к MikroTik, отображение списка папок

    Подключение сетевой папки MikroTik SMB на Windows ПК

    Все действия будут производить со стороны ПК c ОС Windows.

    Подключение к сетевой папке

    Подключение HDD, SSD, flash к MikroTik по IP

    SAMBA авторизация

    Подключение HDD, SSD, flash к MikroTik, авторизация Windows

    Попытка записать файл

    Подключение HDD, SSD, flash к MikroTik, попытка записи файла

    Проверка скорости чтения\записи MikroTik SAMBA

    При тестировании будет использоваться один файл, размер которого чуть менее 2Гб.

    Проверка скорости записи

    Подключение HDD, SSD, flash к MikroTik, запись файла

    Отображение файла в MikroTik SAMBA

    Подключение HDD, SSD, flash к MikroTik, список файлов

    Проверка скорости чтения

    Подключение HDD, SSD, flash к MikroTik, чтение файла

    Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

    Есть вопросы или предложения по установке и настройке MikroTik SAMBA? Активно предлагай свой вариант настройки! Оставить комментарий