Cloud Hosted Router (CHR) – это версия RouterOS, предназначенная для работы в качестве виртуальной машины. Она поддерживает x86 64-битную архитектуру и может использоваться на большинстве популярных гипервизоров, таких как VMWare, Hyper-V, VirtualBox, KVM и других. В CHR по умолчанию включены все функции RouterOS, но модель лицензирования отличается от других версий RouterOS.

  1. CHR в Hetzner
  2. CHR в Contabo
  3. Ошибка при установке в Hetzner
  4. Установка CHR на Ubuntu

Установка MikroTik CHR на VPS, системный требования

Системные требования MikroTik CHR

  • Версия пакета: RouterOS v6.34 или новее;
  • CPU: 64-битный с поддержкой виртуализации;
  • RAM: 128 МБ или больше;
  • HDD: 128 МБ дискового пространства для виртуального жесткого диска CHR (макс.: 16 ГБ).

Провайдер блокирует VPN?

Настройка собственного VPN сервера на базе MikrTik CHR: дата центр в Германии, контролируемая полоса пропускания, неограниченное число подключаемых устройств, безопасный канал связи.

    Какой VPS выбрать для MikroTik CHR на Hetzner и Contabo

    Под минимальные задачи будет достаточно заказать самый бюджетный VPS на ОС Ubuntu или CentOS. Рассмотрим несколько примеров:

    VPS для MikroTik CHR у Hetzner

    Хостинг Hetzner занимает лидирующую позицию в выборе VPS\VDS в европейских дата центрах. У него широкий выбор серверов под любые нужны.

    Для установки MikroTik CHR будет достаточно конфигурации Hetzner CX11.

    Установка MikroTik CHR на VPS, выбор у Hetzner

    VPS для MikroTik CHR у Contabo

    Хостинг Contabo предоставляет более интересные конфигурации для VPS, а также лояльные условия для установки Windows Server.

    Для установки MikroTik CHR будет достаточно конфигурации Contabo VPS 300.

    Установка MikroTik CHR на VPS, выбор у Contabo
    Если MikroTik CHR устанавливается на Hetzner Cloud

    Эти действия нужно совершить перед установкой MikroTik CHR на Hetzner Cloud как общую официальную инструкцию от данного Cloud провайдера.

    Активировать Rescue режим

    Установка MikroTik CHR на Hetzner, активация Rescue

    Зафиксировать временный root пароль

    Установка MikroTik CHR на Hetzner, пароль Rescue

    Как установить MikroTik CHR на VPS Ubuntu

    После заказа VPS на ОС Ubuntu можно приступить к установке, подключение к серверу происходит через протокол SSH с использованием утилиты Putty.

    Узнать сетевые настройки VPS

    apt update
    apt install net-tools unzip -y
    
    route -n
    
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    0.0.0.0 195.123.224.1 0.0.0.0 UG 0 0 0 ens3
    195.123.224.0 0.0.0.0 255.255.248.0 U 0 0 0 ens3
    
    ifconfig
    
    ens3: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 195.123.225.103 netmask 255.255.248.0 broadcast 195.123.231.255
    inet6 fe80::5054:ff:fe8d:b70 prefixlen 64 scopeid 0x20<link>
    inet6 2a02:27aa::949 prefixlen 32 scopeid 0x0<global>
    ether 52:54:00:8d:0b:70 txqueuelen 1000 (Ethernet)
    RX packets 224284 bytes 14489119 (14.4 MB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 803 bytes 81381 (81.3 KB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    В данном выводе нужно зафиксировать IP адрес 195.123.225.103/21 и шлюз 195.123.224.1.

    Установить CHR

    wget --no-check-certificate https://download.mikrotik.com/routeros/6.49.7/chr-6.49.7.img.zip
    
    unzip chr-6.49.7.img.zip
    
    fdisk -l
    
    Disk /dev/sda: 53.7 GB, 53687091200 bytes, 104857600 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk label type: dos
    Disk identifier: 0x000da8dc
    
    dd if=chr-6.49.7.img of=/dev/sda bs=4M oflag=sync
    
    echo 1 > /proc/sys/kernel/sysrq
    echo b > /proc/sysrq-trigger

    Последовательность установки MikroTik CHR

    • Загрузить образ виртуального диска;
    • Использовать ранее загруженный файл образа в качестве виртуального диска;
    • Перезагрузка VPS. При загрузке ОС должен загрузиться образ CHR;
    • Вход в новый CHR. Пользователь по умолчанию – admin, без пароля.

    Как установить CHR на VPS Ubuntu


    Ошибка при установке MikroTik CHR на Hetzner CPX11

    Эта ошибка возникла при выборе VPS типа CPX11 и возможно будет присутствовать на других VPS сборках:

    Booting from Hard Disk…
    Loading system with initrd
    ERROR: could not find disk!
    Please attach it somewhere else.

    Ошибка при установке MikroTIk CHR на Hetzner Cloud

    Решение: выбрать другую сборку VPS, к примеру CX11.

    Настройка MikroTik CHR на VPS

    Версия CHR по своему функционалу не будет отличаться от любого роутера MikroTik. Поэтому для настройки достаточно воспользоваться инструкцией:

    Однако возможен сценарий, когда на MikroTik CHR не определены настройки для сетевого интерфейса:

    У MikroTik CHR статический IP

    /ip address add interface=ether1 address=195.123.225.103 netmask=255.255.248.0
    /ip route add gateway=195.123.224.1 dst-address=0.0.0.0/0 distance=1
    

    У MikroTik CHR автоматический IP(dhcp)

    /ip dhcp-client add disabled=no interface=ether1

    Есть вопросы или предложения по установке и настройке MikroTik CHR? Активно предлагай свой вариант настройки! Оставить комментарий