Инструкция по настройке OpenVPN сервера на роутере MikroTik с RouterOS v7. Рассмотрен пример по настройке MikroTik OpenVPN с возможностью скачать конфигурацию ovpn. Конфигурация содержит современные методы шифрования AES-256 и SHA256, имеет функционал для использования как локального интернет трафика так и через OpenVPN, а также набор сертификатов выпущенных на самом роутере MikroTik.

OpenVPN — свободная реализация технологии виртуальной частной сети (VPN) с открытым исходным кодом для создания зашифрованных каналoв типа точка-точка или сервер-клиенты между компьютерами. Она позволяет устанавливать соединения между компьютерами, находящимися за NAT и сетевым экраном, без необходимости изменения их настроек. Для обеспечения безопасности управляющего канала и потока данных OpenVPN использует библиотеку OpenSSL.

https://настройка-микротик.укр/wp-content/uploads/kak-rabotaet-openvpn.png
OpenVPN исключительный тем, что использует сертификаты SSL для шифрования VPN туннеля. Скорость соединения при этом остаётся на максимуме, а такой метод шифрования позволяет занимать лидирующие места среди надежных и защищенных VPN серверов современности.

Настройка OpenVPN в MikroTik

С выходом версии RouterOS 7 появилась долгожданная поддержка UDP протокола, которая кроме вопроса совместимости VPN клиентов повышала и быстродействие. Это предоставляет возможность корректно подключить клиентов на ОС:

  • Linux;
  • Windows;
  • Android;
  • IOS.

OpenVPN актуален ещё в том случае, если смартфон на Android или IOS перестал поддерживать ранее популярный протокол L2TP+Ipsec. Решением в данном случае будет в переходе на использование IKEv2, Wireguard или OpenVPN. Все эти протоколы поддерживаются и могут быть настроены на роутере MikroTik.

В качестве RouterOS будет использоваться актуальная версия 7.6.

Создание корневого сертификата(CA)

Настройка находится System→Certificates

Настройка OpenVPN MikroTik, создание корневого сертификата Настройка OpenVPN MikroTik, создание корневого сертификата key usage

Нужно настроить OpenVPN в MikroTik?

VPN сервер на базе OpenVPN: шифрование трафика с помощью SSL, высокая скорость работы, поддержка Android, IOS, Windows, Linux.

    Настройка OpenVPN MikroTik, подпись корневого сертификата CA

    Создание сертификата OpenVPN сервера

    Настройка OpenVPN MikroTik, создание сертификата сервера

    Настройка OpenVPN MikroTik, создание сертификата сервера key usage

    Настройка OpenVPN MikroTik, подпись сертификата сервера

    Создание сертификата OpenVPN клиента

    Настройка OpenVPN MikroTik, cоздание сертификата VPN клиента

    Настройка OpenVPN MikroTik, cоздание сертификата VPN клиента key usage

    Настройка OpenVPN MikroTik, подпись сертификата VPN клиента

    Общий список сертификатов для OpenVPN

    Настройка OpenVPN MikroTik, список сертификатов

    Создание IP пула для OpenVPN клиентов

    Настройка находится IP→Pool

    Настройка OpenVPN MikroTik, создание IP пула для OpenVPN клиентов

    Создание OpenVPN профиля

    Настройка находится PPP→Profiles

    Настройка OpenVPN MikroTik, создание OpenVPN профиля

    Добавление учетной записи для OpenVPN пользователя

    Настройка находится PPP→Secrets

    Настройка OpenVPN MikroTik, добавление учетной записи для OpenVPN пользователя

    Параметры OpenVPN сервера

    Настройка находится PPP→Interface→OVPN Server

    Настройка OpenVPN MikroTik, параметры сервера

    Разрешение в Firewall для OpenVPN подключений

    Настройка находится IP→Firewall→Filter Rules

    Настройка OpenVPN MikroTik, правила Firewall

    /ip pool
    add name=Ip-Pool-VPN ranges=192.168.254.100-192.168.254.254
    
    /ppp profile
    add local-address=192.168.254.1 name=VPN-Profile remote-address=Ip-Pool-VPN
    
    /ppp secret
    add name=OpenVPNUser1 profile=VPN-Profile service=ovpn
    
    /interface ovpn-server server
    set auth=sha1,md5,sha256 certificate=46.33.53.183 cipher=\
    blowfish128,aes128,aes256 default-profile=VPN-Profile enabled=yes \
    protocol=udp
    
    /ip firewall filter
    add action=accept chain=input dst-port=1194 in-interface-list=WAN protocol=\
    udp

    Выгрузка сертификата для OpenVPN клиента

    /certificate export-certificate Nastroika-MikroTik.ukr-CA export-passphrase=""
    /certificate export-certificate OpenVPNUser1 export-passphrase=10203040

    Сгенерированные файлы сертификатов будут помещены во внутреннюю память устройства, откуда их нужно скопировать.
    Настройка OpenVPN MikroTik, выгрузка сертификатов

    Создание config файла для OpenVPN клиента

    Конфигурация для OpenVPN клиента будет генерироваться вручную. Для этого нужно создать пустой файл Open-VPN.ovpn и заполнить его данными на основании шаблона:

    client
    dev tun
    remote 192.192.192.192 1194 udp
    nobind
    persist-key
    persist-tun
    remote-cert-tls server
    data-ciphers AES-256-CBC
    cipher AES-256-CBC
    auth-user-pass
    auth SHA256
    # Весь трафик OpenVPN клиента будет заворачиваться на OpenVPN сервер
    redirect-gateway def1
    # Если нужно добавить маршрут в подсеть за OpenVPN сервером
    #route 192.168.1.0 255.255.255.0
    verb 3
    <ca>
    ##**********Сюда нужно вставить содержимое файла cert_export_Nastroika-MikroTik.ukr-CA.crt
    </ca>
    <cert>
    ##**********Сюда нужно вставить содержимое файла cert_export_OpenVPNUser1.crt
    </cert>
    <key>
    ##**********Сюда нужно вставить содержимое файла cert_export_OpenVPNUser1.key
    </key>

    Далее заполненный файл Open-VPN.ovpn нужно скопировать на устройство, которое будет использовать OpenVPN клиент.

    Подключение к OpenVPN MikroTik в Windows

    Со стороны Windows клиента нужно установить приложение с официального сайта(ссылка) и скопировать файл Open-VPN.ovpn в папку OpenVPN\config каталога пользователя или  «Programm Files».

    Настройка OpenVPN MikroTik, подлючение Windows

    При подключении нужно ввести ключ, который был указан при экспорте сертификата пользователя(10203040), после чего следует успешное подключение к OpenVPN серверу, работающему на MikroTik.

    Настройка OpenVPN MikroTik, статус подлючения Windows

    Android OpenVPN подключение к MikroTik

    Настройка OpenVPN MikroTik, подлючение Android

    Настройка OpenVPN MikroTik, статус подлючения Android

    Есть вопросы или предложения по настройке VPN типа OpenVPN MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий