Ethernet over IP (EoIP) Tunneling – это протокол MikroTik RouterOS, который создает туннель Ethernet между двумя маршрутизаторами поверх IP-соединения. Туннель EoIP может работать через туннель IPIP, туннель PPTP или любое другое соединение, способное передавать IP.
Когда функция моста маршрутизатора включена, весь трафик Ethernet (все протоколы Ethernet) будет передаваться по мосту, как если бы между двумя маршрутизаторами был физический интерфейс Ethernet и кабель (с включенным мостом). Этот протокол делает возможным несколько сетевых схем.

Какие преимущества EoIP от MikroTik

Протокол EoIP работает на втором уровне(L2) модели OSI и позволяет:

  1. Использовать одну подсеть для всего множества узлов;
  2. Отправлять в туннель широковещательные запросы;
  3. Корректная работа сетевого окружения;
  4. Высокая скорость работы в малых сетях.

Недостатки VPN туннеля EoIP

На ряду с весомым списком преимуществ использования VPN протокола EoIP он также обладает рядом недостатков:

  1. Присутствие в смежной сети широковещательных запросов;
  2. Нагрузка на интернет канал. В больших сетях широковещательные запросы могут занимать существенную долю трафика.

Настройка EoIP на роутере MikroTik

В конфигурации будут участвовать два роутера(маршрутизатора) MikroTik, задача которых это объединить две сети в одно адресное пространство.

Настройка EoIP на роутере MikroTik

Настройка находится в Interfaces→EoIP Tunnel

Добавление EoIP туннеля на MikroTik-1

Настройка EoIP MikroTik, добавление VPN туннеля на MikroTik-1

/interface eoip
add mac-address=02:D9:DD:FC:26:75 name=eoip-tunnel1 remote-address=\
10.10.10.10 tunnel-id=112

Добавление EoIP туннеля на MikroTik-2

Настройка EoIP MikroTik, Добавление VPN туннеля на MikroTik-2

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

/interface eoip
add mac-address=02:DF:0C:33:16:CA name=eoip-tunnel1 remote-address=\
20.20.20.20 tunnel-id=112

Добавление EoIP туннеля в локальный Bridge

Аналогичную настройку нужно произвести на обоих роутерах, MikroTik-1 и MikroTik-2.

Настройка находится в Bridge→Ports

Настройка EoIP MikroTik, добавление VPN туннеля в локальный Bridge

/interface bridge port
add bridge=BridgeLan interface=eoip-tunnel1

Настройка IP адреса на локальном Bridge для MikroTik-1

Настройка находится в IP→Addresses

Настройка EoIP MikroTik, настройка IP адреса на локальном Bridge для MikroTik-2

/ip address
add address=192.168.33.1/24 interface=BridgeLan network=192.168.33.0

Настройка IP адреса на локальном Bridge для MikroTik-2

Настройка EoIP MikroTik, настройка IP адреса на локальном Bridge для MikroTik-1

/ip address
add address=192.168.33.2/24 interface=BridgeLan network=192.168.33.0

Проверка работы EoIP туннеля

Настройка EoIP MikroTik, проверка работы VPN туннеля

Есть вопросы или предложения по настройке EoIP VPN в MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий