Что такое Socks5

Начиная с прошивки 6.47 на канале stable маршрутизаторы(роутеры) MikroTik начали поддерживать долгожданную функцию proxy сервера Socks5.

Socks (Socket Secure) это протокол, с помощью которого можно отправлять весь трафик на proxy сервер. Но в отличии от стандартного http proxy, socks(v4 и v5) умеет работать с трафиком https.

Настойка Socks5 в MIkroTik, добавление в прошивку

Стоит отметить что Socks5 использует оба протокола UDP и TCP, это позволяет достичь наибольшей производительности и делает Socks5 самым популярным протоколом для связи с proxy сервером.

Ещё одной полезной функцией – возможность авторизации на уровне пользователя. Эта опция не обязательная и может быть не задействована при соединении на Socks5.

Задачи, которые может решить Socks5

Суть Socks5 это перенаправление трафика. Этим свойством можно пользоваться в тех  случаях, когда присутствует запрет на пользование популярных сервисов типа: Telegram, Yandex, Вконтакте и прочими. Трафик переадресовывается через того провайдера, на котором активирован Socks5 и это может быть абсолютно любая страна мира.

Настойка Socks5 в MIkroTik

Настройка Socks5 на роутере MikroTik

Socks5 настраивается в два этапа:

  • Активация Socks5 со стороны MikroTik;
  • Подключение клиента(приложения).

Настройки Socks5 будут рассмотрены последовательно, начиная с основного – активация Socks5 на роутере MikroTik.

Активация Socks5

Настройка находится IP→Socks

Настойка Socks5 в MIkroTik, активация

По умолчанию Port = 1080, но все стандартные порты лучше менять на другие, с целью повышения безопасности роутера MikroTik.

Создание учётной записи для Socks5

Настройка находится IP→Socks→Users

Настойка Socks5 в MIkroTik, создание учётной записи Users

При этом, необходимо изменить метод авторизации на password.

Настойка Socks5 в MIkroTik, изменить метод авторизации на password

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Другие возможности Socks5 в MikroTik

Основные параметры для подключения через Socks5 определены, их можно дополнить двумя разделами:

Настройка Access Socks5

Настройка находится IP→Socks→Access

Настойка Socks5 в MIkroTik, настройка Access

/ip socks
set enabled=yes port=24572 version=5
/ip socks access
add action=deny dst-address=vk.com
/ip socks users
add name=Socks5-User password=Socks5-User

В этом разделе можно определять правила access и deny, создавая некоторые ограничения для использования Socks5.

Раздел Connections

Настройка находится IP→Socks→Connections

Настойка Socks5 в MIkroTik, раздел Connections

Содержит все соединения, которые проходят через Socks5 на текущем маршрутизаторе(роутере) MikroTik.

Настройка Firewall для Socks5 в MikroTik

Базовый Firewall имеет ограничения на входящий трафик(chain=input) и для того, чтобы Socks5 в MikroTik полноценно функционировал, необходимо добавить разрешающее правило(access) выше, чем правило запрета(drop).

Настройка Firewall для Socks5

Настройка находится IP→Firewall→Filter Rules

Настойка Socks5 в MIkroTik, Firewall для Socks5

/ip firewall filter
add action=accept chain=input comment=Socks5 dst-port=24572 \
in-interface-list=WAN protocol=tcp

Подключение к Socks5 MikroTik через Firefox

Ниже будут рассмотрены два вида подключения: с авторизацией и без.

Настройка Firefox для подключения к Socks5 без авторизации

Настойка Socks5 в MIkroTik, Firefox для подключения к Socks5

Настойка Socks5 в MIkroTik, Firefox для подключения к Socks5 без авторизации

Настройка Firefox для подключения к Socks5 с авторизацией

Для этого вида подключения будет задействован внешнее дополнение(Add-on) Proxy Toggle

Настойка Socks5 в MIkroTik, добавить Addon Proxy Toggle

Настойка Socks5 в MIkroTik, настроить Addon Proxy Toggle

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Есть вопросы или предложения по настройке Socket5 в MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий