SSTP (Secure Socket Tunneling Protocol – протокол безопасного туннелирования сокетов) – VPN протокол, основанный на SSL 3.0. Благодаря этому данные шифруются. Аутентификация осуществляется с помощью PPP. Соединение проходит с помощью HTTPS по 443 порту (настраиваемо).

SSTP это разработка компании Miсrosoft, как некий аналог прогрессивным протоколам, которые используют шифрование. Самый прямой аналог в мире VPN служб это OpenVPN, в основе которого лежит:

  • использование сертификатов SSL;
  • низкие требования к аппаратной части(железу);
  • высокая производительность, которая прямо отражается на скорости соединения.

Настройка SSTP VPN сервера на роутере MikroTik

В рамках статьи будут рассмотрены две самые популярные связки: соединение типа роутер-клиент и роутер-роутер:

SSTP туннель между MikroTik и Windows

  • SSTP VPN сервер на роутере MikroTik;
  • SSTP VPN клиент на Windows 10.

Настройка SSTP в MikroTik, туннель между роутером и Windows

SSTP туннель между MikroTik и MikroTik

  • SSTP VPN сервер на роутере MikroTik-1;
  • SSTP VPN клиент на роутере MikroTik-2.

Настройка SSTP в MikroTik, туннель между двумя роутерами


Создание SSL сертификата в MikroTik для работы SSTP VPN сервера

Эта общая настройка, на которую будут ссылаться две последующие конфигурации для Windows клиента, а также для SSTP клиента на второго роутера MikroTik.

Создание сертификата для центра сертификации(CA)

Настройка находится System→Certificates

Настройка SSTP в MikroTik, создание сертификата для центра сертификации(CA)

Указать возможность подписи данным сертификатом других сертификатов

Настройка SSTP в MikroTik, указать возможность подписи данным сертификатом других сертификатов

Подпись CA сертификата

Настройка SSTP в MikroTik, подпись CA сертификата

Результат подписи сертификата и процесс

Настройка SSTP в MikroTik, результат подписи сертификата и процесс

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Создание сертификата SSL для SSTP VPN сервера

Настройка SSTP в MikroTik, создание сертификата SSL для SSTP VPN сервера

Указать возможность использовать этот сертификат в качестве клиентского и серверного сертификата

Настройка SSTP в MikroTik, указать возможность использовать этот сертификат в качестве клиентского и серверного сертификата

Подпись сертификата для SSTP центром сертификации(CA)

Настройка SSTP в MikroTik, подпись сертификата для SSTP центром сертификации(CA)

Сертификаты для работы SSTP VPN сервера в MikroTik

Настройка SSTP в MikroTik, сертификаты для работы SSTP VPN сервера в MikroTik

Настройка SSPT VPN сервера в MikroTik

Создание IP пула для VPN клиентов SSTP

Настройка находится IP→Pool

Настройка SSTP в MikroTik, создание IP пула для VPN клиентов SSTP

/ip pool
add name=Ip-Pool-Vpn ranges=192.168.50.100-192.168.50.254

Добавление VPN профиля

Настройка находится PPP→Profiles

Настройка SSTP в MikroTik, добавление VPN профиля

/ppp profile
add local-address=192.168.50.1 name=VPN-Profile remote-address=Ip-Pool-Vpn

Добавление учетной записи для VPN клиента SSTP

Настройка находится PPP→Secrets

Настройка SSTP в MikroTik, добавление учетной записи для VPN клиента SSTP

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

/ppp secret
add name=user-sstp password=Av3D2eyAF87f profile=VPN-Profile service=sstp

Активация SSTP VPN сервера

Настройка находится PPP→Interface→SSTP Server

Настройка SSTP в MikroTik, активация SSTP VPN сервера

/interface sstp-server server
set authentication=mschap2 certificate=92490a0ea575.sn.mynetname.net \
default-profile=VPN-Profile force-aes=yes

Экспорт SSL сертификата для удаленных SSTP VPN клиентов

Экспорт сертификата CA

Настройка находится System→Certificates

Настройка SSTP в MikroTik, экспорт сертификата для VPN клиента

 

Указать тип сертификата и ключ

Настройка SSTP в MikroTik, указать тип ключа

 

Выгрузка сертификата для VPN клиентов

Настройка находится Files→File List→Download

Настройка SSTP в MikroTik, выгрузка сертификата для VPN клиента

Пример выгруженного сертификата

Настройка SSTP в MikroTik, пример выгруженного сертификата SSL

VPN туннель SSTP между роутером MikroTik и Windows клиентом

Сформированный сертификат SSL на роутере MikroTik необходимо установить на каждом VPN клиенте.

Установка сертификата на локальный компьютер

Настройка SSTP в MikroTik, установка сертификата на локальный компьютер

Выбор хранилища для сертификата

Настройка SSTP в MikroTik, выбор хранилища для сертификата

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Успешный импорт сертификата

Настройка SSTP в MikroTik, успешный импорт сертификата

Создание нового VPN туннеля типа SSTP

Настройка SSTP в MikroTik, создание нового VPN туннеля типа SSTP

Указать адрес и имя VPN соединения

Настройка SSTP в MikroTik, указать адрес и имя VPN соединения

Указать параметры шифрования

Настройка SSTP в MikroTik, указать параметры шифрования

Подключить VPN

Настройка SSTP в MikroTik, подключить VPN

Ввести имя пользователя и пароль

Настройка SSTP в MikroTik, ввести имя пользователя и пароль

Пример успешного VPN соединения

Настройка SSTP в MikroTik, пример успешного VPN соединения

VPN туннель SSTP между двумя роутерами MikroTik

Загрузка сертификата SSL в MikroTik

Настройка находится Files→File List→Upload

Настройка SSTP в MikroTik, загрузка сертификата в MikroTik

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Импорт сертификата

Настройка находится System→Certificates

Настройка SSTP в MikroTik, импорт сертификата SSL

 

Пример импортированного сертификата для SSTP VPN клиента

 

Создание SSTP VPN клиента

Настройка находится PPP→Interface

Настройка SSTP в MikroTik, создание VPN клиента

Настройка SSTP VPN клиента

Настройка SSTP в MikroTik, настройка SSTP VPN клиента на роутере

/interface sstp-client
add authentication=mschap2 certificate=\
cert_export_92490a0ea575.sn.mynetname.net.p12_0 connect-to=\
92490a0ea575.sn.mynetname.net disabled=no name=sstp-out1 password=\
Av3D2eyAF87f profile=default-encryption user=user-sstp

Статус подключения и характеристики VPN клиента

Настройка SSTP в MikroTik, статус подключения и характеристики VPN клиента 

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Есть вопросы или предложения по настройке VPN типа SSTP в MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий