Примеры использования VLAN между MikroTik и Ubiquiti(UniFi, Nanostation)

В продолжении обзорной статьи “Настройка VLAN в MikroTik, trunk и access порты ” будет рассмотрено несколько популярных схем, с участием оборудования Ubiquiti. Данный вендор производит качественную продукцию и многие потребители беспроводных технологий, знакомство с “бесшовным роумингом” начали именно с него.

Нужно настроить VLAN между MikroTik и Ubiquiti?

Мы поможем настроить: маршрутизатор(роутер), точку доступа или коммутатор.

Данные схемы будут основываться на использовании Managment VLAN со стороны Ubiquiti(UniFi, Nanostation), который подразумевает использование отдельной подсети для сетевого оборудования. Как обозначалось ранее, такая основа поможет достойно справиться с наднагрузкой в беспроводной сети WiFi.

VLAN между Ubiquiti(UniFi, Nanostation) и MikroTik, прямое подключение

  • 5-ый порт роутера определен как нетегированный(access);
  • на точке доступа WiFi Ubiquiti(UniFi, Nanostation) активирован Managment VLAN.

VLAN между Ubiquiti(UniFi, Nanostation) и MikroTik, прямое подключение

VLAN между Ubiquiti(UniFi, Nanostation) и MikroTik, через коммутатор MikroTik CSS326-24G-2S+RM

  • 5-ый порт роутера тегированный(trunk);
  • 5-ый порт коммутатора тегированный(trunk);
  • 6 порт коммутатора нетегированный(access).

VLAN между Ubiquiti(UniFi, Nanostation) и MikroTik, через коммутатор MikroTik CSS326-24G-2S+RM

Описание настройки маршрутизатора и точки доступа WiFi будет только касаться VLAN, подразумевается, что остальные службы и настройки включены и не создают препятствий в работе VLAN.

Настройка Ubiquiti(UniFi, Nanostation) Managment VLAN

Активация режима управления точкой доступа WiFi через отдельный VLAN производится через настройку:

Настройка Ubiquiti(UniFi, Nanostation) Managment VLAN

Зачем использовать Bridge в настройке VLAN

Начиная с прошивки RouterOS v6.41 изменилась архитектура обработки VLAN пакетов. Ранее VLAN указывался на интерфейс, на котором он должен быть использован, а в новой прошивки на программный Bridge. На логику работу VLAN это ни каким образом не влияет, но упорядочивает контроль и понимание настройки VLAN на оборудовании MikroTik. Как будет видно из инструкции, в настройке VLAN будут задействованы 4-ре отдельных подраздела(VLAN(Interfaces), Bridge(Bridge), Ports(Bridge), VLANs(Bridge))

VLAN между Ubiquiti(UniFi, Nanostation) и MikroTik, прямое подключение

VLAN между Ubiquiti(UniFi, Nanostation) и MikroTik, прямое подключение

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Добавление нового Bidge и активация использования VLAN

Настройка находится Bridge→Bridge

VLAN между Ubiquiti и MikroTik, создание Bridge

VLAN между Ubiquiti и MikroTik, активация использования VLAN на Bridge

/interface bridge
add admin-mac=6C:3B:6B:C4:59:07 auto-mac=no name=Ether-All-B vlan-filtering=yes

Добавление VLAN на интерфейс Bridge

Настройка находится Interfaces→VLAN

VLAN между Ubiquiti и MikroTik, добавление VLAN

/interface vlan
add interface=Ether-All-B name=Bridge-Vlan17 vlan-id=17
add interface=Ether-All-B name=Bridge-Vlan27 vlan-id=27

Эту настройку нужно распространить для двух VLAN ID – 17 и 27, которые будут назначаться Managment VLAN и клиентам WiFi соответственно.

Добавление портов в Bridge, определение нетегированного(access) порта

Настройка находится Bridge→Ports

VLAN между Ubiquiti и MikroTik, фильтрация трафика по VLAN, настройка access порта

/interface bridge port
add bridge=Ether-All-B interface=Ether9 pvid=27

Настройка Managment порта

Настройка находится Bridge→VLANs

VLAN между Ubiquiti и MikroTik, определение trunk портов

/interface bridge vlan
add bridge=Ether-All-B tagged=Ether-All-B tagged=Ether9 vlan-ids=17

Настройка VLAN для клиентов WiFi

Настройка находится Bridge→VLANs

VLAN между Ubiquiti и MikroTik, определение trunk и access портов

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

/interface bridge vlan 
add bridge=Ether-All-B tagged=Ether-All-B untagged=Ether9 vlan-ids=27

Настройка локального IP адреса для VLAN

Настройка находится IP→Addresses

VLAN между Ubiquiti и MikroTik, настройка IP адреса для VLAN

/ip address
add address=192.168.17.1/24 interface=Bridge-Vlan17 network=192.168.17.0
add address=192.168.27.1/24 interface=Bridge-Vlan27 network=192.168.27.0

Настройка DHCP сервера для VLAN

Настройка находится IP→DHCP Server→DHCP

VLAN между Ubiquiti и MikroTik, настройка DHCP сервера для VLAN

/ip dhcp-server
add address-pool=Pool-LAN-17 disabled=no interface=Bridge-Vlan17 lease-time=\
1d name=dhcp_vlan17
add address-pool=Pool-LAN-27 disabled=no interface=Bridge-Vlan27 lease-time=\ 
1d name=dhcp_vlan27

После подключения к 5-ом порту маршрутизатора(роутера) MikroTik точке доступа WiFi Ubiquiti(UniFi, Nanostation), через опцию точки доступа Managment VLAN присваивается IP 17-ого VLAN, ну а всем WiFi клиентам из 27-ого VLAN.

VLAN между Ubiquiti и MikroTik, успешная настройка

VLAN между Ubiquiti(UniFi, Nanostation) и MikroTik, через коммутатор MikroTik CSS326-24G-2S+RM

VLAN между Ubiquiti(UniFi, Nanostation) и MikroTik, через коммутатор MikroTik CSS326-24G-2S+RM

Чтобы избежать путаницы в настройке VLAN, этот раздел будет описан полностью, даже если часть настроек будет пересекаться с прямой схемой подключения.

Добавление нового Bidge и активация использования VLAN

Настройка находится Bridge→Bridge

VLAN между Ubiquiti и MikroTik +L2, создание Bridge

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

VLAN между Ubiquiti и MikroTik +L2, активация использования VLAN на Bridge

/interface bridge
add admin-mac=2A:59:86:88:2D:4B auto-mac=no name=Bridge-VLAN vlan-filtering=yes

Добавление VLAN на интерфейс Bridge

Настройка находится Interfaces→VLAN

VLAN между Ubiquiti и MikroTik +L2, добавление VLAN интерфейса

/interface vlan
add interface=Bridge-VLAN name=Bridge-Vlan17 vlan-id=17
add interface=Bridge-VLAN name=Bridge-Vlan27 vlan-id=27

Эту настройку нужно распространить для двух VLAN ID – 17 и 27, которые будут назначаться Managment VLAN и клиентам WiFi соответственно.

Добавление портов в Bridge, определение тегированного(trunk) порта

Настройка находится Bridge→Ports

VLAN между Ubiquiti и MikroTik +L2, фильтрация трафика по VLAN, настройка trunk порта

/interface bridge port 
add bridge=Bridge-VLAN interface=ether5 pvid=1

Настройка VLAN для Managment порта

Настройка находится Bridge→VLANs

VLAN между Ubiquiti и MikroTik +L2, определение trunk портов для Managment VLAN

/interface bridge vlan
add bridge=Bridge-VLAN tagged=Bridge-VLAN tagged=ether5 vlan-ids=17

Настройка VLAN для клиентов WiFi

Настройка находится Bridge→VLANs

VLAN между Ubiquiti и MikroTik +L2, определение trunk портов для WiFi клиентов

/interface bridge vlan 
add bridge=Bridge-VLAN tagged=Bridge-VLAN untagged=ether5 vlan-ids=27

Настройка локального IP адреса для VLAN

Настройка находится IP→Addresses

VLAN между Ubiquiti и MikroTik +L2, настройка IP адреса для VLAN

/ip address
add address=192.168.17.1/24 interface=Bridge-Vlan17 network=192.168.17.0
add address=192.168.27.1/24 interface=Bridge-Vlan27 network=192.168.27.0

Настройка DHCP сервера для VLAN

Настройка находится IP→DHCP Server→DHCP

VLAN между Ubiquiti и MikroTik, настройка DHCP сервера для VLAN

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

/ip dhcp-server
add address-pool=Pool-LAN-17 disabled=no interface=Bridge-Vlan17 lease-time=\
1d name=dchp_vlan17
add address-pool=Pool-LAN-27 disabled=no interface=Bridge-Vlan27 lease-time=\ 
1d name=dchp_vlan27

Настройка тегированных и нетегированных портов на коммутаторе MikroTik CSS326-24G-2S+RM

VLAN между Ubiquiti и MikroTik +L2, настройка trunk и access портов на MikroTik 326

Определение на каких портах будут присутствовать VLAN-ы

VLAN между Ubiquiti и MikroTik +L2, опеределение VLAN на портах MikroTik 326

После подключения к 5-ом порту маршрутизатора(роутера) MikroTik точки доступа WiFi Ubiquiti(UniFi, Nanostation), через опцию точки доступа Managment VLAN присваивается IP 17-ого VLAN, ну а всем WiFi клиентам из 27-ого VLAN.

VLAN между Ubiquiti и MikroTik, успешная настройка

Есть вопросы или предложения по настройке VLAN между MikroTik и Ubiquiti? Активно предлагай свой вариант настройки! Оставить комментарий