Инструкция по настройке VPN туннеля типа IpSec между облачным роутером Pfsense и MikroTik. В результате настройки должно получиться объединение двух сетей, за MikroTik и за Pfsense.

Настройка MikroTik VPN сервер L2TP, VPN между офисами

Что такое Pfsense

PfSense — дистрибутив для создания межсетевого экрана/маршрутизатора, основанный на FreeBSD. PfSense предназначен для установки на персональный компьютер, известен своей надежностью и предлагает функции, которые часто можно найти только в дорогих коммерческих межсетевых экранах. Настройки можно проводить через web-интерфейс, что позволяет использовать его без знаний базовой системы FreeBSD. Сетевые устройства с pfSense обычно применяются в качестве периметровых брандмауэров, маршрутизаторов, серверов DHCP/DNS, и в технологии VPN в качестве узла топологии hub/spoke.

Cистемные требования Pfsense

Минимальные
  • CPU – 500 Mhz
  • RAM – 512 MB
Рекомендованные
  • CPU – 1 Ghz
  • RAM – 1 GB
Общие требования
Полная установка
  • CD-ROM или USB
  • HDD – 1 GB

Что такое Pfsense

10-20Mbps Современные (младше 4 лет) процессоры Intel или AMD с тактовой частотой 500 МГц или выше.
21-100 Mbps Современный процессор Intel или AMD с тактовой частотой 1,0 ГГц.
101-500 Mbps Не меньше, чем современный процессор Intel или AMD с тактовой частотой 2,0 ГГц. Оборудование серверного класса с сетевыми адаптерами PCI-e или более новое настольное оборудование с сетевыми адаптерами PCI-e.
501+ Mbps Требуется несколько ядер с тактовой частотой> 2,0 ГГц. Оборудование серверного класса с сетевыми адаптерами PCI-e.

Настройка VPN в MikroTik для подключения к Pfsense

Со стороны роутера MikroTik будет настроен стандартный VPN туннель типа IpSec. Больше сведений по настройке VPN типа IpSec представлено в статье:

VPN туннель IpSec состоит из двух фаз:

  • PHASE-1 – идентификация устройств между собой, по заранее определенному IP адресу и ключу.
  • PHASE-2 – определение политики для трафика между туннелей: шифрование, маршрутизация, время жизни туннеля.

Создание профиля для MikroTik IpSec phase-1

Настройка находится в IP→IPsec→Profile

Pfsense и MikroTik, создание профиля для IpSec phase-1

Создание Peer для MikroTik IpSec phase-1

Настройка находится в IP→IPsec→Peers

Pfsense и MikroTik, создание Peer для IpSec phase-1

Определение ключа MikroTik IpSec phase-1

Настройка находится в IP→IPsec→Identities

Pfsense и MikroTik, определение ключа IpSec phase-1

Настройка параметров MikroTik Proposal IpSec phase-2

Настройка находится в IP→IPsec→Proposals

Pfsense и MikroTik, настройка параметров Proposal IpSec phase-2

Создание политики(Policies) MikroTik IpSec phase-2

Настройка находится в IP→IPsec→Policies

Pfsense и MikroTik, создание политики(Policies) IpSec phase-2

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Настройка политики(Policies) MikroTik IpSec phase-2

Настройка находится в IP→IPsec→Policies→Action

Pfsense и MikroTik, настройка политики(Policies) IpSec phase-2

/ip ipsec profile
add dh-group=modp1024 enc-algorithm=3des hash-algorithm=md5 lifetime=8h name=Pfsense
/ip ipsec peer
add address=10.10.10.10/32 name=Pfsense profile=Pfsense
/ip ipsec proposal
add auth-algorithms=md5 enc-algorithms=3des lifetime=8h name=Pfsense
/ip ipsec policy
add dst-address=192.168.5.0/24 peer=Pfsense proposal=Pfsense \
sa-dst-address=10.10.10.10 sa-src-address=0.0.0.0 src-address=\
192.168.1.0/24 tunnel=yes
/ip ipsec identity
add peer=Pfsense secret=Pt36ENepT3t3

Настройка VPN в Pfsense для подключения к MikroTik

Pfsense имеет удобный web интерфейс, с помощью которого и будет производиться настройка VPN туннеля типа IpSec для связи с роутером MikroTik.

Настройка phase-1 для Pfsense IpSec

Создание phase-1 для Pfsense IpSec

Создание phase-1 для Pfsense IpSec, выбор шифрования

Настройка phase-2 для Pfsense IpSec

Настройка phase-2 для Pfsense IpSec

Настройка phase-2 для Pfsense IpSec, шифрование

Настройка phase-2 для Pfsense IpSec, общие параметры

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Настройка Pfsense Firewall

Настройка Pfsense Firewall, разрешение внешнего подключения IpSec

Настройка Pfsense Firewall, обмен трафиком внутри VPN

Результат настройки VPN IpSec между Pfsense и MikroTik

После успешно принятых настроек, проверить соединение VPN типа IpSec между Pfsense и MikroTik можно так:

Pfsense и MikroTik, статус VPN туннеля IpSec

MikroTik и Pfsense, статус VPN IpSec туннеля

Есть вопросы или предложения по настройке DNS сервера в MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий