Часто можно встретить задачу, когда:

  • конфигурацию с маршрутизатора(роутера) MikroTik нужно перенести на другое устройство в связи с заменой;
  • происходит настройка нескольких аналогичных устройств MikroTik.

И во всех этих задачах было бы рациональным использовать метод переноса конфигурации. Он будет состоять из двух этапов:

  1. Выгрузка конфигурации с устройства источника MikroTik-1;
  2. Загрузка конфигурации в устройство назначение MikroTik-2.

Методы переноса настроек между устройствами MikroTik

Действия со стороны устройства источника(MikroTik-1)

Для переноса конфигурации между маршрутизаторами(роутерами), коммутаторами(свитчами) или точками доступа WiFi MikroTik можно воспользоваться двумя распространенными методами:

С иcпользованием файла BACKUP

/system backup save name=Backup-File

С использование скрипт файла

/export file=Backup-Script.rsc

Копирование конфигурации MikroTik на другой роутер, коммутатор или точку доступа, создание Backup

Копирование конфигурации MikroTik на другой роутер, коммутатор или точку доступа, копирование Backup

Оба файла будут созданы во внутренней памяти устройства. Но какая разница между этими методами? При создании скриптового файла, его можно изменить перед применением. Это позволит:

  • Установить другой IP адрес на интерфейс;
  • Изменить MAC адрес;
  • Параметры DHCP сервера;
  • другие настройки.

Действие со стороны устройства приемника(MikroTik-2)

Метод переноса настроек посредством Backup подходит только для оборудования одной модели.

Импорт файла типа Backup

Данный файл необходимо перенести во внутреннюю память устройства, а затем нажать кнопку “Restore” и указать backup файл.

Копирование конфигурации MikroTik на другой роутер, коммутатор или точку доступа, импорт файла типа Backup

Устройство будет перезагружено, а перенесенная конфигурация применена.

Применение скрипт файла

Полученный файл читается через любой текстовый редактор. Конечную версию конфигурации нужно скопировать в буфер обмена(выделить текст и Ctrl+C) и вставить(Ctrl+V) в терминальное окно со стороны конечного устройства MikroTik.

Пример копирования настроек MikroTik

В качестве примера будут выступать два  маршрутизатора(роутера) MikroTik RB2011UiAS-2HnD-IN, которые после обновления сетевой инфраструктуры будут выполнять роль обычных коммутаторов(с точкой доступа). В качестве метода по переносу настроек между устройствами MikroTik будет выбран метод скрипта, который позволит предварительно подготовить конфигурацию в текстовом файле, для исключения дальнейшей донастройки коммутатора.

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Со стороны коммутатора MikroTik-1

Будет выгружена конфигурация

/export file=Backup-Script.rsc

и скопирована на ПК для редактирования. Будут изменены такие настройки:

  • MAC адрес локального Bridge. Новый MAC адрес будет отличаться на +1 в адресе;
  • IP адрес Bridge.

По разделам это такие блоки:

/interface bridge
add admin-mac=B2:F6:3B:C5:33:36 auto-mac=no name=Bridge-LAN
/ip address
add address=10.224.1.9/24 interface=Bridge-LAN network=10.224.1.0

Со стороны коммутатора MikroTik-2

Подготовленный скрипт необходимо скопировать во внутреннюю память устройства. А следующий шаг произведет одновременно два действия:

  • Процедуру “Reset“;
  • Выполнение скрипта после сброса.

Настройка находится System→Reset Configuration

Копирование конфигурации MikroTik на другой роутер, коммутатор или точку доступа, перенос на устройство назначение

И после перезагрузки останется только установить пароль для администратора устройства, который в таком виде(не зашифрованном) не переносится.

ЕСЛИ конфигурация в виде скрипта не загрузилась после перезагрузки нужно:

  1. Открыть файл Backup-Script.rsc в любом текстовом редакторе и скопировать весь текст;
  2. Открыть окно терминала Winbox-а(Terminal), вставить и выполнить скопированные команды.

Перенос настроек в MikroTik с ошибкой

Очень часто процедура копирования настроек между двумя роутерами MikroTik закачивается без успеха. Выводится ошибка или после перезагрузки роутер MikroTik попросту не работает.

Для того, чтобы выяснить какая именно ошибка, подойдёт только метод с использованием файла типа RSC. На моменте, где будет возникать ошибка будет происходить остановка выполнения срипта.

Частые ошибки при копировании настроек в MikroTik

  1. Разные прошивки;
  2. У MikroTik-1 есть модуль WiFi на 5ГГц, а у MikroTik-2 он отсутствует;
  3. У MikroTik-1 есть порт SFP, а у MikroTik-2 он отсутствует;
  4. Разное количество портов.

Есть вопросы или предложения по копированию настроек в MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий