В инструкции будет рассмотрена настройка UPnP в MikroTik, а в качестве наглядного примера будет подключён видеорегистратор Dahua. На выходе образуется инфраструктура, в которой нет необходимости пробрасывать порты для просмотра видеонаблюдения, UPnP полностью автоматизирует этот процесс.

MikroTik RouterOS поддерживает архитектуру Universal Plug and Play для прозрачного однорангового сетевого подключения персональных компьютеров и интеллектуальных устройств или устройств, подключенных к сети.

UPnP обеспечивает обмен данными между любыми двумя устройствами под управлением любого управляющего устройства в сети. Universal Plug and Play полностью не зависит от какого-либо физического носителя. Он поддерживает работу в сети с автоматическим обнаружением без какой-либо начальной настройки, в результате чего устройство может динамически присоединяться к сети. Серверы DHCP и DNS не являются обязательными и будут использоваться, если они доступны в сети. UPnP реализует простое, но мощное решение для обхода NAT, которое позволяет клиенту получить полную поддержку двусторонней одноранговой сети за NAT-ом.

Для UPnP существует два типа интерфейса: internal (тот, к которому подключены локальные клиенты) и external (тот, к которому подключен Интернет). Маршрутизатор может иметь только один внешний интерфейс с «общедоступным» IP-адресом и столько внутренних интерфейсов, сколько необходимо, все с «внутренними» IP-адресами с NAT.

Протокол UPnP используется для многих современных приложений, таких как большинство игр DirectX, а также для различных функций Windows Messenger (удаленная поддержка, совместное использование приложений, передача файлов, голос, видео) из-за брандмауэра.

Как настроить UPnP в MikroTik

Для того, чтобы роутер MikroTik начал взаимодействовать с другими устройствами по протоколу UPnP нужно:

  1. Активировать использование UPnP;
  2. Определить локальные(internal) и внешние(external) интерфейсы.

Описание параметров UPnP

enabled – активирует UPnP службу;

allow-disable-external-interfaceследует ли разрешать пользователям отключать внешний интерфейс маршрутизатора MikroTik. Эта функция добавлена отдельным параметром и регулирует режим совместимости для тех сетей, где UPnP нежелателен или его работа не предусмотрена;

show-dummy-rule – активация обходного пути для некоторых неработающих реализаций, которые неправильно обрабатывают отсутствие правил UPnP (например, появляются сообщения об ошибках). Эта опция проинструктирует сервер установить фиктивное (бессмысленное) правило UPnP, которое могут соблюдать клиенты, которые в противном случае отказываются работать правильно.

Настройка находится IP→UPnP

Активация режима UPnP

Настройка UPnP MikroTik, активация режима

Определить internal и external интерфейсы

Настройка находится IP→UPnP→Interfaces

Настройка UPnP MikroTik, определить internal и external интерфейсы

/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=Bridge-LAN type=internal
add interface=ether1 type=external

Пример настройки UPnP MikroTik в видеорегистраторе Dahua

На любом устройстве, поддерживающего технологию UPnP достаточно включить данный режим. Все правила со стороны роутера MikroTik создадутся автоматически

Активация UPnP в Dahua

Настройка UPnP MikroTik, активация в Dahua

Пробросы портов через UPnP

Настройка находится IP→Firewall→NAT

Настройка UPnP MikroTik, пробросы портов через UPnP

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Есть вопросы или предложения по настройке UPnP в MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий