Задача: настроить два WAN порта от одного провайдера одной подсети в роутере MikroTik

Казалось бы типичная настройка по конфигурированию статического IP адреса на интерфейсе, но на практике, когда добавляется второй статический адрес, маршрут 0.0.0.0\0 в автоматическом режиме переключается на второй интерфейс. Чтобы поэтапно представить проблему, будет описан каждый шаг:

Добавляется статический IP адрес на интерфейс ether1

Настройка находиться Ip→Addesses

Настройка маршрутизации для двух провайдеров в MikroTik, добавить статический IP для WAN-1

Указывается маршрут для выхода в интернет через шлюз провайдера

Настройка находиться Ip→Routes

Настройка маршрутизации для двух провайдеров в MikroTik, добавить статический маршрут для WAN-1

При это видно, что шлюз определяется на интерфейсе ether1

Добавляется второй IP адрес на интерфейсе ether2 в той же подсети

Настройка находиться Ip→Addesses

Настройка маршрутизации для двух провайдеров в MikroTik, добавить статический IP для WAN-2

Без добавление второго маршрута, таблица маршрутизации выглядит такие образом

Настройка находиться Ip→Routes

Настройка маршрутизации для двух провайдеров в MikroTik, реакция таблицы маршрутизации на добавление второго IP адреса из той же подсети

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

/ip address
add address=81.21.12.15/27 interface=ether1 network=81.21.12.0
add address=81.21.12.20/27 interface=ether2 network=81.21.12.0
/ip route
add distance=1 gateway=81.21.12.1

При этом видно, что маршрут на 0.0.0.0\0 сам перестроился на ether2. Ответ на вопрос “почему так происходит” определяется последней записью в таблице маршрутизации, которая возвращается на запрос: через какой интерфейс отправлять пакеты типа 0.0.0.0\0.

Как указать явно интерфейс в таблице маршрутизации MikroTik для статического IP в одной подсети

Для решении это задачи, достаточно после IP адреса шлюза, через символ % указать наименование интерфейса. Это должно выглядеть так:

Настройка маршрутизации для двух провайдеров в MikroTik, явно указать интерфейс, через который будет проходить трафик

Настройка маршрутизации для двух провайдеров в MikroTik

Этот раздел будет содержать описание входящего и исходящего трафик только для маршрутизатора(роутера) MikroTik. Это делается для того, чтобы роутер MikroTik отправлял ответ на тот интерфейс, с которого пришел запрос. Если этим пренебречь, то ответ на ping интерфейса WAN-2 будет проходить через WAN-1, а это не совсем корректно, не правда ли?

Для каждого из WAN интерфейсов нужно создать 2 правила для цепочки input и output:

Настройка маршрутизации для двух провайдеров в MikroTik, определение входящего интерфейса

Настройка маршрутизации для двух провайдеров в MikroTik, маркировка входящего подключения

Настройка маршрутизации для двух провайдеров в MikroTik, определение исходящего интерфейса

Настройка маршрутизации для двух провайдеров в MikroTik, маркировка маршрута для WAN-1

/ip firewall mangle
add action=mark-connection chain=input in-interface=ether1 \
new-connection-mark=From-WAN-1 passthrough=yes
add action=mark-routing chain=output connection-mark=From-WAN-1 \
new-routing-mark=To-WAN-1 passthrough=yes
add action=mark-connection chain=input in-interface=ether2 \
new-connection-mark=From-WAN-2 passthrough=yes
add action=mark-routing chain=output connection-mark=From-WAN-2 \
new-routing-mark=To-WAN-2 passthrough=yes

А дальше обратиться к таблице маршрутизации и указать через какие шлюзы будут отправляться запросы

Настройка маршрутизации для двух провайдеров в MikroTik, создание маршрута для WAN1

Настройка маршрутизации для двух провайдеров в MikroTik, создание маршрута для WAN2

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

/ip route
add distance=1 gateway=192.168.30.1%ether1 routing-mark=To-WAN-1
add distance=1 gateway=192.168.30.1%ether2 routing-mark=To-WAN-2

Как ограничить скорость для двух провайдеров используя Mangle и Simple Queues в новой статье “Настройка ограничение скорости в MikroTik, Simple Queues для двух провайдеров

Есть вопросы или предложения по настройке DualWAN в MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий