Исходная конфигурация роутера MikroTik

За основу задачи по ограничению скорости лежит пример со статьи “Настройка в MikroTik двух статических IP на двух портах одной подсети, DualWan конфигурация “, в которой рассмотрена реализация настройки двух статических IP одной подсети, но на разных интерфейсах.

Пример настройка ограничения скорости в MikroTik для двух провайдеров

Очередь по обработки трафика должна содержать правила, которые обеспечат работу следующего алгоритма:

  • Существует приоритетная группа узлов, которым должно резервироваться 60% пропускной способности интернет канала.
  • Всем остальным узлам(кроме гостевой сети) отводится остальные 40% канала.
  • Если интернет каналы не заняты по группе приоритета или по резервированию, то любому подключению отводится 100% ширины канала.
  • Гостевой сети отводится скорость 10Мб, с низким приоритетом. Это означает почти полное отсутствие интернета, если корпоративные узлы запросят 100% скорости.

Настройка по ограничению скорости будет состоять из последовательности:

  1. Приоритетные узлы будут разбиты на две группы, WAN-1 и WAN-2.
  2. Каждый из групп(WAN-1 или WAN-2) будет маршрутизироваться в отдельный интернет канал.
  3. Чтобы управлять очередью по ограничению скорости будет принято правило: трафик групп WAN-1 и WAN-2 будет маркироваться(через Mangle), резервируя 60% канала. Весь остальной трафик будет распределяться между двумя провайдерами с резервом 40%.
  4. Правила по ограничению скорости будут выставлены каскадно, в соответствии с представленным тех. заданием.

Создание Access List в MikroTik, для управление группами IP

Исходя из проекта-решения, группа предоставленных IP будет разделена на два access list-а, для удобства дальнейшего управления или масштабирования.

Настройка находится IP→Firewall→Adress Lists

Настройка ограничение скорости в MikroTik, создание Access List в MikroTik, для управление группами IP

/ip firewall address-list
add address=192.168.10.0/24 list=Local-Subnet
add address=192.168.10.122 list=WAN-1
add address=192.168.10.102 list=WAN-1
add address=192.168.10.182 list=WAN-1
add address=192.168.10.132 list=WAN-1
add address=192.168.10.108 list=WAN-2
add address=192.168.10.115 list=WAN-2
add address=192.168.10.242 list=WAN-2

Маркировка маршрута для группы WAN-1

Это правило будет направлять весь внешний трафик группы на интерфейс WAN-1.

Настройка находится IP→Firewall→Mangle

Настройка ограничение скорости в MikroTik, маркировка маршрута(prerouting) для группы WAN-1

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Настройка ограничение скорости в MikroTik, маркировка маршрута(srс. address list) для группы WAN-1

Настройка ограничение скорости в MikroTik, маркировка маршрута(mark routing) для группы WAN-1

Аналогичные действия нужно произвести для Access List-а WAN-2.

Маркировка пакетов входящего трафика(download)

Это правило будет использовать в разделе ограничения скорости Simple Queues.

Настройка ограничение скорости в MikroTik, маркировка пакетов(forwarding) входящего трафика(download)

Настройка ограничение скорости в MikroTik, маркировка пакетов(dst. address list) входящего трафика(download)

Настройка ограничение скорости в MikroTik, маркировка пакетов(mark packet) входящего трафика(download)

Аналогичное правило для исходящего трафика(upload)

Настройка ограничение скорости в MikroTik, маркировка пакетов(forwarding) входящего трафика(download)

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Настройка ограничение скорости в MikroTik, маркировка пакетов(src. address list) входящего трафика(upload)

Настройка ограничение скорости в MikroTik, маркировка пакетов(mark packet) входящего трафика(upload)

Аналогичные действия нужно произвести для Access List-а WAN-2.

Вид раздела Mangle после создания все правил маркировки маршрутов и пакетов

Настройка ограничение скорости в MikroTik, вид раздела Mangle после создания все правил маркировки маршрутов и пакетов

/ip firewall mangle
add action=mark-connection chain=input in-interface=ether1 \
new-connection-mark=From-WAN-1 passthrough=yes
add action=mark-routing chain=output connection-mark=From-WAN-1 \
new-routing-mark=To-WAN-1 passthrough=yes
add action=mark-connection chain=input in-interface=ether2 \
new-connection-mark=From-WAN-2 passthrough=yes
add action=mark-routing chain=output connection-mark=From-WAN-2 \
new-routing-mark=To-WAN-2 passthrough=yes
add action=mark-routing chain=prerouting dst-address-list=!Local-Subnet \
new-routing-mark=To-WAN-1 passthrough=yes src-address-list=WAN-1
add action=mark-routing chain=prerouting dst-address-list=!Local-Subnet \
new-routing-mark=To-WAN-2 passthrough=yes src-address-list=WAN-2
add action=mark-packet chain=forward dst-address-list=WAN-1 new-packet-mark=\
To-WAN-1-Down passthrough=yes
add action=mark-packet chain=forward new-packet-mark=To-WAN-1-Up passthrough=\
yes src-address-list=WAN-1
add action=mark-packet chain=forward dst-address-list=WAN-2 new-packet-mark=\
To-WAN-2-Down passthrough=yes
add action=mark-packet chain=forward new-packet-mark=To-WAN-2-Up passthrough=\
yes src-address-list=WAN-2

Статическая маршрутизация в MikroTik с использованием Mangle

Возвращаясь к исходному заданию, необходимо задействовать две линии интернета с двумя видами распределения. Группы Access List будут делиться руками, а все остальные подключения, будут распределяться по каналам по принципу “нечетный – налево, четные – направо”.

Определение трафика группы WAN-1 на первую линию интернета WAN-1

Настройка находится IP→Routes

Настройка ограничение скорости в MikroTik, определение трафика группы WAN-1 на первую линию интернета WAN-1

Определение трафика группы WAN-2 на вторую линию интернета WAN-2

Настройка ограничение скорости в MikroTik, определение трафика группы WAN-2 на вторую линию интернета WAN-2

Все остальные подключения равномерно делятся между провайдерами

Настройка ограничение скорости в MikroTik, все остальные подключения равномерно делятся между провайдерами

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Вид раздела Routes после добавления всех статических маршрутов

Настройка ограничение скорости в MikroTik, вид раздела Routes после добавления всех статических маршрутов

/ip route
add distance=1 gateway=81.21.12.1%ether1 routing-mark=To-WAN-1
add distance=1 gateway=81.21.12.1%ether2 routing-mark=To-WAN-2
add distance=1 gateway=81.21.12.1%ether2,81.21.12.1%ether1

Пример настройки Simple Queues в MikroTik для двух провайдеров с использованием Mangle

Все маршруты и пакеты промаркированы и созданный статические маршруты по распределению трафика между двумя линиями интернета(аналог двух провайдеров). Остается только задать правила ограничения скорости. ВНИМАНИЕ! Будут использоваться параметры приоритета.

Создание общего правила ограничения скорости для всего интернет канала WAN-1

Данные правила содержат приоритет 7(высокий).

Настройка находится Queue→Simple Queues

Настройка ограничение скорости в MikroTik, создание общего правила ограничения скорости для всего интернет канала WAN-1

Создание Simple Queues для приоритетной группы WAN-1 трафика типа “download”

Настройка ограничение скорости в MikroTik, создание Simple Queues для приоритетной группы WAN-1 входящего трафика

Настройка ограничение скорости в MikroTik, создание Simple Queues для приоритетной группы WAN-1 трафика типа download

Создание Simple Queues для приоритетной группы WAN-1 трафика типа “upload”

Настройка ограничение скорости в MikroTik, создание Simple Queues для приоритетной группы WAN-1 исхощяго трафика

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Настройка ограничение скорости в MikroTik, создание Simple Queues для приоритетной группы WAN-1 трафика типа upload

Создание Simple Queues для остального трафика текущей подсети

Данные правила содержат приоритет 8(низкий).

Настройка ограничение скорости в MikroTik, создание Simple Queues для остального трафика

Настройка ограничение скорости в MikroTik, создание Simple Queues для остального трафика с лимитом

Аналогичные действия нужно произвести для пакетов To-WAN-2-Down и To-WAN-2-Up для интернет канала WAN-2.

Создание Simple Queues для гостевой сети

Настройка ограничение скорости в MikroTik, создание Simple Queues для гостевой сети

/queue simple
add dst=ether1 max-limit=95M/95M name=Queue-WAN-1 target=192.168.10.0/24
add dst=ether2 max-limit=95M/95M name=Queue-WAN-2 target=\
192.168.10.0/24,192.168.11.0/24
add dst=ether1 limit-at=0/60M max-limit=0/95M name=WAN-1-Down packet-marks=\
To-WAN-1-Down parent=Queue-WAN-1 priority=7/7 target=192.168.10.0/24
add dst=ether2 limit-at=0/60M max-limit=0/95M name=WAN-2-Down packet-marks=\
To-WAN-2-Down parent=Queue-WAN-2 priority=6/6 target=192.168.10.0/24
add dst=ether1 limit-at=60M/0 max-limit=95M/0 name=WAN-1-Up packet-marks=\
To-WAN-1-Up parent=Queue-WAN-1 priority=7/7 target=192.168.10.0/24
add dst=ether2 limit-at=60M/0 max-limit=95M/0 name=WAN-2-Up packet-marks=\
To-WAN-2-Up parent=Queue-WAN-2 priority=6/6 target=192.168.10.0/24
add dst=ether1 limit-at=35M/35M max-limit=95M/95M name=WAN-1-Other parent=\
Queue-WAN-1 target=192.168.10.0/24
add dst=ether2 limit-at=35M/35M max-limit=95M/95M name=WAN-2-Other parent=\
Queue-WAN-2 priority=7/7 target=192.168.10.0/24
add dst=ether2 max-limit=10M/10M name=WAN-2-Guest parent=Queue-WAN-2 target=\
192.168.11.0/24

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Есть вопросы или предложения по настройке ограничения скорости в MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий