Что такое VPN и где применяется

VPN сервер популярное средство для удаленного подключения одного ПК(или 100 ПК) к центральному узлу, а также для объединения офисов. Реализация такого сервиса есть масса, но на MikroTik работает быстро и без инцидентов по недоступности.

Для удаленного доступа сотрудников

Доступ к рабочему пространству с любого места, где есть интернет. Почта, сетевые папки, принтер, 1с – все это становится доступным.

Объединение офисов

Компьютеры, та и вся техника смогут обмениваться информацией вне зависимости от географического расположения.

Доступ к облачному серверу

Закрытый канал для доступа к корпоративному или частному серверу, расположенному в облаке.

Настройка Mikrotik PPTP VPN сервер

Нужно настроить VPN сервер PPTP в MikroTik?

Мы поможем настроить: маршрутизатор(роутер), точку доступа или коммутатор.

Чем отличается PPTP от L2TP и других VPN серверов

PPTP – самый распространенный протокол VPN. Представляет собой связку протокола TCP, который используется для передачи данных, и GRE – для инкапсуляции пакетов. Чаще всего применяется для удаленного доступа пользователей к корпоративной сети. В принципе, может использоваться для многих задач VPN, однако следует учитывать его изъяны в безопасности – отсутствие шифрования. Данные передаваемые в туннеле PPTP могут быть подвержены зеркалированию в другой интернет канал, что подвергает опасности коммерческой информации.

Специалисты Настройка-Микротик.укр НЕ РЕКОМЕНДУЮТ использовать данный вид VPN туннелей для передачи коммерческой информации.

В качестве рабочих решений по организации удаленного доступа могут выступать любые VPN сервера с поддержкой шифрования: L2TP, IpSec.

Чем отличается PPTP от L2TP и других VPN серверов

Как настроить PPTP VPN сервер в MikroTik

Для VPN клиентов создаётся отдельная подсеть, это добавит больше возможностей в ограничении доступа между VPN клиентами и локальной сетью, а также в самой маршрутизации. Другими словами эта реализация обеспечивает сетевую безопасность на уровне Firewall-а.

Добавление новой подсети

Настройка находится IP->Pool

Настройка MikroTik VPN сервер PPTP, создание подсети IP Pool

/ip pool add name=LAN-Ip-Pool ranges=192.168.10.100-192.168.10.150

Настройка VPN сервера PPTP(на сервере)

Настройка находится PPP->Profile

Предварительно нужно задать сетевые параметры для VPN клиентов

Настройка MikroTik VPN сервер PPTP, настройка профиля VPN сервера

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

/ppp profile
add dns-server=192.168.10.1 local-address=\
192.168.10.1 name=VPN-Server remote-address=VPN-Ip-Pool

Активация VPN сервера PPTP

Настройка находится PPP->Interface->PPTP Server

Настройка MikroTik VPN PPTP сервер, активация

/interface pptp-server server
set authentication=mschap2 default-profile=VPN-Server enabled=yes

Создание учётной записи для VPN клиента

Этой учётной записью будет пользоваться VPN клиент для удаленного подключения к VPN серверу.

Настройка находится PPP->Interface->Secrets

Настройка MikroTik VPN сервер PPTP, создание учётной записи VPN клиента на сервере

/ppp secret
add name=user1 password=user1 service=pptp profile=VPN-Server

Разрешение FireWall для подключения VPN клиентов

Настройка находится IP->Firewall

Настройка MikroTik VPN сервер PPTP, добавление правила FireWall 1723

Настройка MikroTik VPN сервер PPTP, добавление правила FireWall Accept

/ip firewall filter
add action=accept chain=input comment="Port Access" dst-port=1723 \
in-interface-list=WAN-Interface-List protocol=tcp

Настройка интернета для VPN клиентов PPTP в MikroTik

Этот вопрос будет вынесен за рамки данной статьи, т.к. относится с дополнительным сервисам для VPN клиентов. Таких сервисов может быть множество и все они имеют индивидуальных характер(для тех кто ищет: нужно настроить и разрешить DNS запросы и Masquerade).

Нужна настройка MikroTik?

Настройка сервисов на маршрутизаторах MikroTik: подключение интернета, DHCP, brige, VLAN, WiFi, Capsman, VPN, IpSec, PPTP, L2TP, Mangle, NAT, проброс портов, маршрутизация(routing), удаленное подключение и объединение офисов.

    VPN подключение PPTP между двумя MikroTik-ами, объединение офисов

    В этой настройке будут участвовать два роутера MikroTik, один в качества сервера, другой в качестве клиента. На этапе создание такого подключения стоит обратить внимание на модель MikroTik, т.к. от неё зависит количество VPN подключений, а также возможность обрабатывать такие потоки данных. Для консультации по этому вопросу обращайтесь в Настройка-Микротик.укр через контактную форму.

    Настройка MikroTik VPN сервер PPTP, VPN между офисами

    Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

    Для объединения двух офисов и работы маршрутизации данную настройку лучше разбить на два блока:

    1. Настройка клиент-серверной части;
    2. Добавление статических маршрутов для прохождения трафика.

    Серверная часть была описана ваше, но требует корректировки в виде статических адресов для VPN клиента

    Настройка находится PPP->Interface->Secrets

    Настройка MikroTik VPN сервер PPTP, настройка учётной записи VPN клиента на сервере

    /ppp secret
    add local-address=192.168.10.1 name=user2 password=user2 profile=VPN-Server \
    remote-address=192.168.10.2

    а клиентская часть состоит из настройки PPTP клиента.

    Настройки PPTP клиента(на клиенте)

    Настройка находится PPP->Interface->+PPTP Client

    Настройка MikroTik VPN сервер PPTP, добавление VPN клиента

    Настройка MikroTik VPN сервер PPTP, настройка VPN клиента

    /interface pptp-client
    add connect-to=90.200.100.99 disabled=no name=\
    pptp-out1 password=user2 user=user2

    Настройка маршрутизации со стороны VPN сервера

    Это правило укажет роутеру MikroTik куда направлять трафик.

    Настройка находится IP->Routes

    Настройка MikroTik VPN сервер PPTP, добавление статического маршрута на сервере

    /ip route
    add distance=1 dst-address=192.168.88.0/24 gateway=192.168.10.2

    где

    • 192.168.88.0/24 – сеть за 2-ым MikroTik-ом, который выступает в роли ppptp клиента;
    • 192.168.10.2 – IP адрес 2-ого MikroTik-а.

    Настройка маршрутизации со стороны VPN клиента

    Настройка находится IP->Routes

    Настройка MikroTik VPN сервер PPTP, добавление статического маршрута на клиенте

    Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

    /ip route
    add distance=1 dst-address=192.168.0.0/24 gateway=192.168.10.1

    где

    • 192.168.5.0/24 – сеть 1-ого MikroTik-ом, который выступает в роли ppptp сервера;
    • 192.168.10.1 – IP адрес 1-ого MikroTik-а.

    Создание VPN подключения PPTP Windows

    ОС семейства Windows имеют штатный VPN клиент, который отлично подходит под эту роль. Для его настройки нужно перейти

    Панель управления\Сеть и Интернет\Центр управления сетями и общим доступом

    создание Windows VPN клиента

    Настройка MikroTik VPN сервер L2TP, создание Windows VPN клиента

    выбор нового подключения

    Настройка MikroTik VPN сервер L2TP, выбор нового подключения

    использовать текущее подключение к интернету

    Настройка MikroTik VPN сервер L2TP, использовать текущее подключение к интернету

    указать адрес VPN сервера

    Настройка MikroTik VPN сервер PPTP, указать адрес VPN сервера

    настройка VPN клиента Windows

    Настройка MikroTik VPN сервер PPTP, настройка VPN клиента Windows

    подключение Windows VPN

    Настройка MikroTik VPN сервер L2TP, подключение Windows VPN

    статус подключения Windows VPN

    Настройка MikroTik VPN сервер L2TP, статус подключения Windows VPN

    Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

    Есть вопросы или предложения по настройке VPN типа PPTP MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий