В данном примере будет рассмотрена настройка отправки email через устройство MikroTik с RouterOS. Устройство будет использоваться только как почтовый клиент, т.е. email адрес должен будь актуальным и доступным.

Практически задачи, когда может пригодиться:

  1. Система оповещения когда: обрывается связь, необходимо оповестить о состоянии устройства или другое событие;
  2. Отправка backup на внешний ящик.

В качестве примера будет рассмотрен первый случай: имеется интернет соединение, изменение статуса которого будет сопровождаться соответствующим письмом.

Подключение email(почтового ящика) в MikroTik

Email предварительно был зарегистрирован в gmail.com и в качестве дополнительной опции была указана опция удаленного управления через приложение в разделе безопасности.

Настройка отправки email в MikroTik через Netwatch, разрешить подключение приложений к gmail

Настройка отправки email в MikroTik через Netwatch, безопасность gmail

Этот параметр следует учитывать не только с gmail, но и с большинством других почтовых сервисов.

Со стороны MikroTik нужно настроить одноименный раздел Email, который будет содержать все авторизационные данные для отправки писем.

Настройка находится Tools→Email

Настройка отправки email в MikroTik через Netwatch, подключение к почтовому ящику

/tool e-mail
set address=173.194.220.108 [email protected] password=mikrotik.config.ukr \
port=587 start-tls=yes [email protected]

Отправка email в случае обрыва интернета в MikroTik

Наблюдение за событием обрыва интернета будет производиться с помощью утилиты Netwatch. Суть её работы в том, что утилита отправляет ICMP запросы на определенный IP и в зависимости от состояния(UP или DOWN) выполняет определенный скрипт. В данном примере это будет отправка email.

В качестве IP адреса рекомендуется указывать шлюз(gateway) или DNS сервер интернет провайдера.

Настройка находится Tools→Netwatch

Настройка отправки email в MikroTik через Netwatch, настройка PING

Понравилась статья, отблагодари автора, посмотри рекламу. СпасибоПоддержи автора статьи, сделай клик по рекламе ↓↓↓

Настройка отправки email в MikroTik через Netwatch, отправки email при состоянии UP

Настройка отправки email в MikroTik через Netwatch, отправки email при состоянии DOWN

/tool netwatch
add down-script="tool e-mail send [email protected] subject=\"\
Internet is DOWN\" body=\"\"" host=8.8.8.8 interval=10s up-script="tool e-\
mail send [email protected] subject=\"Internet is UP\" bod\
y=\"\""

Netwatch в MikroTik не работает, что делать

Элементарная команда Ping может не приносить требуемого результата если в системе больше одного провайдера или маршрутизация настроена таким образом, что при падении канала узел(Host) остается доступным. В этом случае рекомендуется обратиться к разделу Firewall, добавив правило, которое блокирует иные варианты маршрутизации для ICMP запросов.

Настройка находится IP→Firewall

Настройка отправки email в MikroTik, когда не работает Netwatch

Настройка Mikrotik winbox, правило firewall drop

/ip firewall filter
add action=drop chain=output dst-address=8.8.8.8 out-interface=!ether3

Есть вопросы или предложения по настройке отправки email через Netwatch в MikroTik? Активно предлагай свой вариант настройки! Оставить комментарий